PDA

Vollständige Version anzeigen : Netzlaufwerk verbinden und Passwort und Benutzerkennung speichern


Uwe Afemann[_2_]
October 15th 08, 11:24 AM
Hallo,
ich arbeite mit Windows XP Professional SP 3 in einer Arbeitsgruppe,
also ohne Domänenanbindung.
Bisher hatte ich eine feste Verbindung zu einem Samba-Server mit einer
vom Windows-Login verschiedenen Kennungen. Die Benutzerkennung und das
Passwort für diese Verbindung hatte ich über "Benutzerkonten - Eigene
Netzwerkkennwörter verwalten" gespeichert. Nun habe ich das Passwort
dieser Verbindung geändert und versucht dies über die gleiche
Schnittstelle nachzuhalten. Doch beim Neuanmelden unter Windows kam die
Verbindung nie zustande. Ich musste im Explorer immer auf das Laufwerk
klicken und wurde dann aufgefordert das Passwort einzugeben, d. h. das
gespeicherte Passwort wurde nicht erkannt oder benutzt.
Dann habe ich die Einträge für diese Verbindung über "Benutzerkonten -
Eigene Netzwerkkennwörter verwalten" erst gelöscht und dann wieder neu
eingetragen. Doch leider wird die Verbindung beim Anmelden nicht wieder
hergestellt. Ich muss immer erst auf das Laufwerk im Explorer klicken,
um dann dass Passwort einzugeben. Der Benutzername ist aber richtig
vorgegeben.
Eine Netzwerkverbindung wird ja in der Registry vermerkt.
Unter HKCU\Network\<Laufwerksbuchstabe> finden sich ja die Einträge für
permanente Verbindungen. Falls der Eintrag DeferFlags auf 1 steht,
wird auch der Username ausgewertet. Steht DeferFlags aus 4, wird der
Eintrag ignoriert und es wird der Loginname der Windowssitzung verwendet.
Wie bekomme ich es hin, dass meine gewünschte Netzlaufwerksverbindung
wieder automatisch zustande kommt.
Manuell kann ich die Verbindung herstellen, d. h. die Kombination aus
Benutzername und Passwort ist korrekt.
Welche Syntax muss ich evtl. im entsprechenden Dialog verwenden
1. für den Server, z. B. \\meinsamba.de\freigabename oder
meinsamba.de\freigabename
Ich habe beide Varianten ausprobiert.
2. für den Benutzernamen, z. B. Rechnername\Benutzer oder
Benutzer@Rechnername, wobei Rechnername der Rechnername des Windows-PC
ist. Nur den "Benutzer" anzugeben ist nicht möglich.

Was mache ich falsch? Was habe ich evtl. übersehen?

Mit freundlichen Grüßen
Uwe

Ralf Breuer
October 15th 08, 11:43 AM
Uwe Afemann > schrieb:

Hallo Uwe,

> ich arbeite mit Windows XP Professional SP 3 in einer Arbeitsgruppe,
> also ohne Domänenanbindung.
> Bisher hatte ich eine feste Verbindung zu einem Samba-Server mit einer
> vom Windows-Login verschiedenen Kennungen. Die Benutzerkennung und das
> Passwort für diese Verbindung hatte ich über "Benutzerkonten - Eigene
> Netzwerkkennwörter verwalten" gespeichert. Nun habe ich das Passwort
> dieser Verbindung geändert und versucht dies über die gleiche
> Schnittstelle nachzuhalten. Doch beim Neuanmelden unter Windows kam
> die Verbindung nie zustande.

Lösche über "Benutzerkonten - Eigene Netzwerkkennwörter verwalten" die
Einträge und verbinde das Laufwerk manuell. Klicke dabei auf "Verbindung
unter anderem Benutzer herstellen". Haken bei "Verbindung bei Anmeldung
wiederherstellen" nicht vergessen. Die Eingaben werden automatisch korrekt
bei den Netzkennwörtern eingetragen.

--
Gruß
Ralf
Ich mag kein TOFU. Siehe http://einklich.net/usenet/zitier.htm
Bei Direkt-Mails NOSPAM entfernen

Uwe Afemann[_2_]
October 15th 08, 12:35 PM
Ralf Breuer schrieb:
> Uwe Afemann > schrieb:
>
> Hallo Uwe,
>
>> ich arbeite mit Windows XP Professional SP 3 in einer Arbeitsgruppe,
>> also ohne Domänenanbindung.
>> Bisher hatte ich eine feste Verbindung zu einem Samba-Server mit einer
>> vom Windows-Login verschiedenen Kennungen. Die Benutzerkennung und das
>> Passwort für diese Verbindung hatte ich über "Benutzerkonten - Eigene
>> Netzwerkkennwörter verwalten" gespeichert. Nun habe ich das Passwort
>> dieser Verbindung geändert und versucht dies über die gleiche
>> Schnittstelle nachzuhalten. Doch beim Neuanmelden unter Windows kam
>> die Verbindung nie zustande.
>
> Lösche über "Benutzerkonten - Eigene Netzwerkkennwörter verwalten" die
> Einträge und verbinde das Laufwerk manuell. Klicke dabei auf "Verbindung
> unter anderem Benutzer herstellen". Haken bei "Verbindung bei Anmeldung
> wiederherstellen" nicht vergessen. Die Eingaben werden automatisch
> korrekt bei den Netzkennwörtern eingetragen.
>
Hallo Ralf,
vielen Dank für deinen Vorschlag, doch leider funktioniert das nicht.
Nach einer Neuanmeldung bekomme ich dann die Meldung:
"Es konnten nicht alle Netzlaufwerke wiederhergestellt werden".
Sieht man unter Benutzerkonten - Eigene Netztwerkkennwörter verwalten"
nach, so wurde die per Hand gemachte Verbindung nicht eingetragen.

Gruß
Uwe

Ralf Breuer
October 15th 08, 12:45 PM
Uwe Afemann > schrieb:

> vielen Dank für deinen Vorschlag, doch leider funktioniert das nicht.
> Nach einer Neuanmeldung bekomme ich dann die Meldung:
> "Es konnten nicht alle Netzlaufwerke wiederhergestellt werden".
> Sieht man unter Benutzerkonten - Eigene Netztwerkkennwörter verwalten"
> nach, so wurde die per Hand gemachte Verbindung nicht eingetragen.

Das bemerke ich auch manchmal. Eine Wiederholung des Vorgangs führt meist
zum Ziel.

--
Gruß
Ralf
Ich mag kein TOFU. Siehe http://einklich.net/usenet/zitier.htm
Bei Direkt-Mails NOSPAM entfernen

Uwe Afemann[_2_]
October 15th 08, 01:37 PM
Ralf Breuer schrieb:
> Uwe Afemann > schrieb:
>
>> vielen Dank für deinen Vorschlag, doch leider funktioniert das nicht.
>> Nach einer Neuanmeldung bekomme ich dann die Meldung:
>> "Es konnten nicht alle Netzlaufwerke wiederhergestellt werden".
>> Sieht man unter Benutzerkonten - Eigene Netztwerkkennwörter verwalten"
>> nach, so wurde die per Hand gemachte Verbindung nicht eingetragen.
>
> Das bemerke ich auch manchmal. Eine Wiederholung des Vorgangs führt
> meist zum Ziel.
>
Hallo Ralf,
wie häufig muss man es denn probieren und wie muss die Sonne stehen.

Im Ernst, wenn man eine Druckerverbindung einrichtet, dann wird diese
permanent unter "Eigene Netzwortkennwörter verwalten" automatisch
eingetragen. Ein automatisches Eintragen eine Netzwerk-Verbindung habe
ich noch nie erlebt.
Übrigens habe ich deinen Vorschlag tatsächlich mehrfach ausgeführt,
leider ohne Erfolg.

Gruß
Uwe

Ralf Breuer
October 15th 08, 03:05 PM
Uwe Afemann > schrieb:

> wie häufig muss man es denn probieren und wie muss die Sonne stehen.

Es geht nur bei Vollmond und dreimal im Kreis drehen ;-)

> Im Ernst, wenn man eine Druckerverbindung einrichtet, dann wird diese
> permanent unter "Eigene Netzwortkennwörter verwalten" automatisch
> eingetragen. Ein automatisches Eintragen eine Netzwerk-Verbindung habe
> ich noch nie erlebt.

Dann klick mal in der Netzwerkumgebung auf den Server. Du solltest jetzt
nach Benutzer/Passwort gefragt werden. Gib die mal ein und setze den Haken
bei "Kennwort speichern". Das findest Du dann bei den Netzwerkkennwörtern
wieder.

--
Gruß
Ralf
Ich mag kein TOFU. Siehe http://einklich.net/usenet/zitier.htm
Bei Direkt-Mails NOSPAM entfernen

Uwe Afemann[_2_]
October 15th 08, 04:10 PM
Ralf Breuer schrieb:
> Uwe Afemann > schrieb:
>
>> wie häufig muss man es denn probieren und wie muss die Sonne stehen.
>
> Es geht nur bei Vollmond und dreimal im Kreis drehen ;-)
>
>> Im Ernst, wenn man eine Druckerverbindung einrichtet, dann wird diese
>> permanent unter "Eigene Netzwortkennwörter verwalten" automatisch
>> eingetragen. Ein automatisches Eintragen eine Netzwerk-Verbindung habe
>> ich noch nie erlebt.
>
> Dann klick mal in der Netzwerkumgebung auf den Server. Du solltest jetzt
> nach Benutzer/Passwort gefragt werden. Gib die mal ein und setze den
> Haken bei "Kennwort speichern". Das findest Du dann bei den
> Netzwerkkennwörtern wieder.
>
Hallo Ralf,
vielen Dank für deine Bemühungen. Aber bisher hilft das noch nicht weiter.
Einmal wird der Samba-Server nicht in der Netzwerkumgebung angezeigt und
zum anderen werden die Verbindungsdaten nicht unter "Eigene
Netzwortkennwörter verwalten" abgelegt.
Solche Daten stehen in:
HKCU\Software\Microsoft\Protected Storage System
Provider\<SID>\Data\5e7e8100-... \00000000-...

Jedenfalls wurden dort z. B. meine ftp-Verbindungen gespeichert und
leider nicht unter der anderen Adresse.

Trotzdem vielen Dank

Uwe

Ralf Breuer
October 15th 08, 04:57 PM
Uwe Afemann > schrieb:

> vielen Dank für deine Bemühungen. Aber bisher hilft das noch nicht
> weiter. Einmal wird der Samba-Server nicht in der Netzwerkumgebung
> angezeigt

Warum nicht? NetBios über TCP/IP ist aktiviert?
Alternativ "Computer suchen".

> und zum anderen werden die Verbindungsdaten nicht unter
> "Eigene Netzwortkennwörter verwalten" abgelegt.
> Solche Daten stehen in:
> HKCU\Software\Microsoft\Protected Storage System
> Provider\<SID>\Data\5e7e8100-... \00000000-...
>
> Jedenfalls wurden dort z. B. meine ftp-Verbindungen gespeichert und
> leider nicht unter der anderen Adresse.

ftp != smb

Dann versuche den Eintrag manuell:

Server: Der NetBios-Name des Samba-Servers ohne Schrägstriche und ohne
Freigabenamen

Benutzername: Servername-wie-oben\Benutzername

Kennwort: wie in Samba vergeben

--
Gruß
Ralf
Ich mag kein TOFU. Siehe http://einklich.net/usenet/zitier.htm
Bei Direkt-Mails NOSPAM entfernen

Uwe Afemann[_2_]
October 16th 08, 08:24 AM
Ralf Breuer schrieb:
> Uwe Afemann > schrieb:
>
>> vielen Dank für deine Bemühungen. Aber bisher hilft das noch nicht
>> weiter. Einmal wird der Samba-Server nicht in der Netzwerkumgebung
>> angezeigt
>
> Warum nicht? NetBios über TCP/IP ist aktiviert?
> Alternativ "Computer suchen".
>
>> und zum anderen werden die Verbindungsdaten nicht unter
>> "Eigene Netzwortkennwörter verwalten" abgelegt.
>> Solche Daten stehen in:
>> HKCU\Software\Microsoft\Protected Storage System
>> Provider\<SID>\Data\5e7e8100-... \00000000-...
>>
>> Jedenfalls wurden dort z. B. meine ftp-Verbindungen gespeichert und
>> leider nicht unter der anderen Adresse.
>
> ftp != smb
>
> Dann versuche den Eintrag manuell:
>
> Server: Der NetBios-Name des Samba-Servers ohne Schrägstriche und ohne
> Freigabenamen
>
> Benutzername: Servername-wie-oben\Benutzername
>
> Kennwort: wie in Samba vergeben
>
Hallo Ralf,
jetzt hat es endlich geklappt. Dein Hinweis, den Server ohne
Schrägstriche und Freigabenamen anzugeben, war wohl ein Teil der Lösung.
Ich habe also so etwas wie meinsamba.de als Server eingetragen und als
Benutzername NetBiosname\Benutzername, wobei der NetBiosname, der meiner
Workstation (Windowskiste) ist und Benutzername ein registrierter
Benutzer des Samba-Servers ist.
Erst danach habe ich eine Netzlaufwerksverbindung hergestellt ohne den
auf "Verbindung unter einem anderem Benutzernamen herstellen" zu
klicken. Vielleicht lag es daran?
Übrigens ist der Samba-Server kein Windows-Rechner und hat daher auch
keinen NetBios-Namen.
Die Verbindungsdaten werden nicht unter Protected Storage System
Provider in der Registry eingetragen, eine über "Netzwerkumgebung
hinzufügen" im Windows-Explorer eingegebene ftp-Verbindung schon.
Letztere wird dann aber auch nicht unter "Eigene Netzwortkennwörter
verwalten" angezeigt.

Vielen Dank für deine Hilfe.


Gruß
Uwe

Ralf Breuer
October 16th 08, 01:45 PM
Uwe Afemann > schrieb:

> jetzt hat es endlich geklappt. Dein Hinweis, den Server ohne
> Schrägstriche und Freigabenamen anzugeben, war wohl ein Teil der
> Lösung. Ich habe also so etwas wie meinsamba.de als Server
> eingetragen und als Benutzername NetBiosname\Benutzername, wobei der
> NetBiosname, der meiner Workstation (Windowskiste) ist und
> Benutzername ein registrierter Benutzer des Samba-Servers ist.

Warum nicht der NetBios-Name des Servers?

> Erst danach habe ich eine Netzlaufwerksverbindung hergestellt ohne den
> auf "Verbindung unter einem anderem Benutzernamen herstellen" zu
> klicken. Vielleicht lag es daran?
> Übrigens ist der Samba-Server kein Windows-Rechner

Samba für Windows wäre mal ein super-flüssiges Produkt ;-)

> und hat daher auch keinen NetBios-Namen.

Ähh, /etc/samba/smb.conf:

workgroup = arbeitsgruppe
netbios name = meinsamba

> Vielen Dank für deine Hilfe.

bitte :-)

--
Gruß
Ralf
Ich mag kein TOFU. Siehe http://einklich.net/usenet/zitier.htm
Bei Direkt-Mails NOSPAM entfernen

Google